魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院:如何编写趋势共振套装指标上(主图源码)

图片[1]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

编写需求:

“小白,我看到有大神在用主副的结合的趋势波动指标,主图是趋势线指标,要能区分当下趋势,最好是均线多头排列后,形成一根上升趋势线,均线空头排列后,也形成一根下降趋势线,而没有多头排列或空头排列,就形成一根震荡趋势线。主趋势线不要太滞后。幅图,类似六脉神剑指标,就是6个幅图指标共振,比如MACD、KDJ、RSI,BBI,LWR.MTM这六个指标,至少5个都金叉或死叉时,出现信号提示。主副图合并在一起使用。”

主图需求,就三点:

  1. 上升趋势,用红色线代表均线多头排列;
  2. 下降趋势,用绿色线代表均线空头排列;
  3. 震荡行情,用黄色线来表达震荡。

效果展示:

图片[2]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

图片[3]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

代码实现:

IsMainIndex:=myinput(1);
Parm1:=myinput(3);
Parm2:=myinput(5);
Parm3:=myinput(7);
Parm4:=myinput(9);
Parm5:=myinput(11);
Parm6:=myinput(13);
Parm7:=myinput(21);
Parm8:=myinput(6);

由于要求趋势线还不能太滞后。那我们就不能用太大的周期,然后再把均线多次平均下

【VARE_1:=(H+C+O+L)/4;
VARE_Parm1:=(EMA(VARE_1,Parm1)+EMA(VARE_1,2*Parm1)+EMA(VARE_1,4*Parm1))/3;
VARE_Parm2:=(EMA(VARE_1,Parm2)+EMA(VARE_1,2*Parm2)+EMA(VARE_1,4*Parm2))/3;
VARE_Parm3:=(EMA(VARE_1,Parm3)+EMA(VARE_1,2*Parm3)+EMA(VARE_1,4*Parm3))/3;
VARE_Parm4:=(EMA(VARE_1,Parm4)+EMA(VARE_1,2*Parm4)+EMA(VARE_1,4*Parm4))/3;
VARE_Parm5:=(EMA(VARE_1,Parm5)+EMA(VARE_1,2*Parm5)+EMA(VARE_1,4*Parm5))/3;
VARE_Parm6:=(EMA(VARE_1,Parm6)+EMA(VARE_1,2*Parm6)+EMA(VARE_1,4*Parm6))/3;
VARE_Parm7:=(EMA(VARE_1,Parm7)+EMA(VARE_1,2*Parm7)+EMA(VARE_1,4*Parm7))/3;
SC_1:=FORCAST(VARE_Parm1,Parm8);
SC_2:=FORCAST(VARE_Parm2,Parm8);
SC_3:=FORCAST(VARE_Parm3,Parm8);
SC_4:=FORCAST(VARE_Parm4,Parm8);
SC_5:=FORCAST(VARE_Parm5,Parm8);
SC_6:=FORCAST(VARE_Parm6,Parm8);
SC_7:FORCAST(VARE_Parm7,Parm8),COLORYELLOW,LINETHICK2;
DT1:=SC_1>=REF(SC_1,1);
DT2:=SC_2>=REF(SC_2,1);
DT3:=SC_3>=REF(SC_3,1);
DT4:=SC_4>=REF(SC_4,1);
DT5:=SC_5>=REF(SC_5,1);
DT6:=SC_6>=REF(SC_6,1);
DT7:=SC_7>=REF(SC_7,1);
KT1:=SC_1<REF(SC_1,1);
KT2:=SC_2<REF(SC_2,1);
KT3:=SC_3<REF(SC_3,1);
KT4:=SC_4<REF(SC_4,1);
KT5:=SC_5<REF(SC_5,1);
KT6:=SC_6<REF(SC_6,1);
KT7:=SC_7<REF(SC_7,1);
DT:=COUNT(DT1+DT2+DT3+DT4+DT5+DT6+DT7>=5,1)
KT:=COUNT(KT1+KT2+KT3+KT4+KT5+KT6+KT7>=5,1)
DRAWICON(CROSS(DT=1,0.5),0.999*SC_7,1);
DRAWICON(CROSS(KT=1,0.5),0.999*SC_7,2);
DQSX:IF(DT=1,SC_7,DRAWNULL),COLORRED,LINETHICK2;
KQSX:IF(KT=1,SC_7,DRAWNULL),COLORGREEN,LINETHICK2;

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院,期魔方专业量化投研平台,能给用户提供期货量化平台软件-期货指标编写-麦语言-期货行情分析-期货多账户管理-期货量化交易策略编写-编写指标-MT4toCTP,为金融从业人员更多专业决策辅助。

请登录后发表评论

    没有回复内容