魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院:如何编写趋势共振套装指标下(副图源码)

图片[1]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

编写需求:

“小白,我看到有大神在用主副的结合的趋势波动指标,主图是趋势线指标,要能区分当下趋势,最好是均线多头排列后,形成一根上升趋势线,均线空头排列后,也形成一根下降趋势线,而没有多头排列或空头排列,就形成一根震荡趋势线。主趋势线不要太滞后。幅图,类似六脉神剑指标,就是6个幅图指标共振,比如MACD、KDJ、RSI,BBI,LWR.MTM这六个指标,至少5个都金叉或死叉时,出现信号提示。主副图合并在一起使用。”

效果展示(幅图):

图片[2]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

代码实现:

IsMainIndex:=myinput(0);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
AA1:=DIF>DEA;
AA2:=DIF<DEA;                      
DRAWTEXT(ISLASTBAR=1,0,'.MACD'),COLORYELLOW;
DRAWICON(AA1,0.5,34);
DRAWICON(AA2,0.5,35);
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),12,1))/(SMA(ABS(CLOSE-LC),12,1))*100;
BB1:=RSI1>RSI2;
BB2:=RSI1<RSI2;
DRAWTEXT(ISLASTBAR=1,1,'.RSI'),COLORYELLOW;
DRAWICON(BB1,1.5,34);
DRAWICON(BB2,1.5,35);
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
CC1:=K>D;
CC2:=K<D;
DRAWTEXT(ISLASTBAR=1,2,'.KDJ'),COLORYELLOW;
DRAWICON(CC1,2.5,34);
DRAWICON(CC2,2.5,35);
RSV:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
DD1:=LWR1>LWR2;
DD2:=LWR1<LWR2;
DRAWTEXT(ISLASTBAR=1,3,'.LWR'),COLORYELLOW;
DRAWICON(DD1,3.5,34);
DRAWICON(DD2,3.5,35);
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
DRAWTEXT(ISLASTBAR=1,4,'.BBI'),COLORYELLOW;
EE1:=C>BBI;
EE2:=C<BBI;
DRAWICON(EE1,4.5,34);
DRAWICON(EE2,4.5,35);
MTM:=CLOSE-REF(CLOSE,MIN(BARSCOUNT(C),12));
MTMMA:=MA(MTM,6);
FF1:=MTM>MTMMA;
FF2:=MTM<MTMMA;
DRAWTEXT(ISLASTBAR=1,5,'.MTM'),COLORYELLOW;
DRAWICON(FF1,5.5,34);
DRAWICON(FF2,5.5,35);
VARE1:=AA1+BB1+CC1+DD1+EE1+FF1>=5;
VARE2:=AA2+BB2+CC2+DD2+EE2+FF2>=5;
DRAWICON(VARE1,7,1);
DRAWICON(VARE2,7,2);
DRAWICON(VARE1,8,1);
DRAWICON(VARE2,8,2);

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院,期魔方专业量化投研平台,能给用户提供期货量化平台软件-期货指标编写-麦语言-期货行情分析-期货多账户管理-期货量化交易策略编写-编写指标-MT4toCTP,为金融从业人员更多专业决策辅助。

请登录后发表评论

    没有回复内容