魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院:经典指标顶底之王案例编写(附带源码)

图片[1]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

编写需求:

顶底的判断,一直是交易者在实际交易中的难题。众多交易者都尝试过抄底摸顶的操作,其中不乏成功的案例,但更多的可能是以失败告终。我们来看一款指标,这是曾经被很多大神用作顶底监控的指标。

效果展示:

从图中可以看出,该指标的顶底提示相对较为及时。

图片[2]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

图片[3]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

源码展示:

ZF_1:=(((C - REF(C,1)) / REF(C,1)) * 100);
ZF_2:=(((C - LLV(L,18)) / (HHV(H,18) - LLV(L,18))) * 100);
JX_1:=SMA(ZF_2,9,1);
JX_2:=SMA(JX_1,3,1);
JQJX:=((3 * JX_1) - (2 * JX_2)), LINETHICK2 , COLORRED;
JQJX_XS:=(JQJX > (1 * REF(JQJX,1)));
ZQZD:=LLVBARS(L,50);
ZDCJL:=SUM(VOL,ZQZD);
ZQZG:=HHVBARS(H,50);
ZGCJL:=SUM(VOL,ZQZG);
ZQZF:=(((C - REF(O,ZQZG)) / REF(O,ZQZG)) * 100);
ZQCCL:=((ZGCJL / VOLINSTK) * 100);
ZQZF_1:=(((C - REF(O,ZQZD)) / REF(O,ZQZD)) * 100);
ZQCCL_1:=((ZDCJL /VOLINSTK) * 100);
JQJX_1:=EMA(JX_1,3); 
JQJX_2:EMA(JX_1,3),COLORWHITE,LINETHICK2;
JQJX_3:EMA(JQJX_2,3),COLORYELLOW;
JQJX_4:EMA(JQJX_3,3),COLORYELLOW;
JQJX_5:EMA(JQJX_4,3),COLORYELLOW;
JQJX_6:EMA(JQJX_5,3),COLORYELLOW;
JQJX_7:EMA(JQJX_6,3),LINETHICK2,COLORRED;
JQJX_5_1:EMA(JQJX_5,6),COLORFF0000;
ZF_ZX:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100;
ZF_ZX_1:=SMA(SMA(ZF_ZX,3,1),3,1)/28.57;
JQJX_ZF:=EMA(ZF_ZX_1,5);
JQJX_ZX:=3*ZF_ZX_1-2*JQJX_ZF;
JC:=CROSS(JQJX_ZX,ZF_ZX_1) AND ZF_ZX_1<2.1 AND C>O;
DRAWICON(JC,JQJX_2*0.9,1);
DRAWTEXT(JC,JQJX_2*0.7,'多头'),COLORRED;
SC:=CROSS(ZF_ZX_1,JQJX_ZX) AND ZF_ZX_1 >2.5 AND C<O;
DRAWICON(SC,JQJX_2*1.1,2); 
DRAWTEXT(SC,JQJX_2*1.3,'空头'),COLORGREEN;

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院,期魔方专业量化投研平台,能给用户提供期货量化平台软件-期货指标编写-麦语言-期货行情分析-期货多账户管理-期货量化交易策略编写-编写指标-MT4toCTP,为金融从业人员更多专业决策辅助。

请登录后发表评论

    没有回复内容