魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院:如何实现MACD面积背离指标(附带源码)

图片[1]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

编写需求:

做一个MACD面积标注的指标,红柱面积与绿柱面积分开计算,一次金叉与死叉周期内的柱体面积累加。红柱标记为红色,绿柱标记为绿色

效果展示:

图片[2]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

代码实现:

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:2*(DIF-DEA),COLORSTICK;
S_1:=SUM(MACD,BARSLAST(MACD<0)),COLOR0000FF,NODRAW;
S_2:=SUM(MACD,BARSLAST(MACD>0)),COLORFFFF00,NODRAW;
AA:=ROUND(REF(S_2,1)*100);
BB:=ROUND(REF(S_1,1)*100);
DRAWNUMBER(CROSS(0,MACD),HHV(REF(MACD,1),5)+0.03,ABS(BB)),COLORMAGENTA;
DRAWNUMBER(CROSS(MACD,0),LLV(REF(MACD,1),5)-0.03,ABS(AA)),COLORGREEN;

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院,期魔方专业量化投研平台,能给用户提供期货量化平台软件-期货指标编写-麦语言-期货行情分析-期货多账户管理-期货量化交易策略编写-编写指标-MT4toCTP,为金融从业人员更多专业决策辅助。

请登录后发表评论

    没有回复内容