魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院:顶底分型编写(附带源码)

图片[1]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

编写需求:

顶底分型,一直以来都是很多技术战法所参考的技术指标。

粉丝私信内容:

【顶分型:3根K线中,中间的K线最高价最大,最低价最大,同时右侧K线的最低价要小于左侧K线的最低价,此为顶分型。底分型:3根K线中,中间的K线最高价最小,最低价最小,同时右侧K线的最高价要大于左侧K线的最高价,此为底分型。】

3根K线,中间的K线最高价和最低价,要么都最大,要么都最小。

同时右侧K线最低价小于左侧K线最低价位顶分型

图片[2]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

右侧K线最高价大于左侧K线最低价为底分型。

图片[3]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

效果展示:

图片[4]|魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

源码展示:

IsMainIndex:=myinput(1);
UPFX:=L>REF(L,1)&&REF(L,2)>REF(L,1)&&H>REF(H,1)&&REF(H,2)>REF(H,1)&&H>REF(H,2);
DOWNFX:=L<REF(L,1)&&REF(L,2)<REF(L,1)&&H<REF(H,1)&&REF(H,2)<REF(H,1)&&L<REF(L,2);
VAR1:=BACKSET(UPFX,3);
VAR2:=BACKSET(DOWNFX,3);
STICKLINE(VAR1&&C>O,O,C,3,1),COLORYELLOW;
STICKLINE(VAR1&&C>O,H,L,0,1),COLORYELLOW;
STICKLINE(VAR1&&C<=O,O,C,3,0),COLORYELLOW;
STICKLINE(VAR1&&C<=O,H,L,0,0),COLORYELLOW;
STICKLINE(VAR2&&C>O,O,C,3,1),COLORGREEN;
STICKLINE(VAR2&&C>O,H,L,0,1),COLORGREEN;
STICKLINE(VAR2&&C<=O,O,C,3,0),COLORGREEN;
STICKLINE(VAR2&&C<=O,H,L,0,0),COLORGREEN;

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院,期魔方专业量化投研平台,能给用户提供期货量化平台软件-期货指标编写-麦语言-期货行情分析-期货多账户管理-期货量化交易策略编写-编写指标-MT4toCTP,为金融从业人员更多专业决策辅助。

请登录后发表评论

    没有回复内容