魔方学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方学院:经典云图指标编写(附带源码)

图片[1]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

编写需求:

市场的交易者,从交易性质分为预测性质的左侧交易,跟踪性质的右侧交易。而市场中也有结合两者性质的指标,即云图指标。

效果展示:

红绿色云图,为预测性指标,代表多空可能。红色云为多,绿色云为空。

紫色线为基准线,价格在基准线之上为多,价格在基准线之下为空。

当云图为红,价格又首次站上基准线时,为多头。

当云图为绿,价格又首次跌破基准线时,为空头。

图片[2]|魔方学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

源码展示:

IsMainIndex:=myinput(1);
Parm1:=myinput(9);
Parm2:=myinput(26);
Parm3:=myinput(52);
RH:=REFX(H,Parm2);
RO:=REFX(O,Parm2);
RC:=REFX(C,Parm2);
RL:=REFX(L,Parm2);
AA:=(HHV(RH,120)-LLV(RL,120))/30,LINETHICK;
VAR1:=(2*RC+RH+RL)/4;
转换线:(HHV(H,Parm1)+LLV(L,Parm1))/2,COLORAAFF99,LINETHICK;
基准线:(HHV(H,Parm2)+LLV(L,Parm2))/2,COLORFF6DD8,LINETHICK;
迟行带:REFX(CLOSE,Parm3),COLORFF9224;
先行带A:REF((转换线+基准线)/2,Parm2),COLORYELLOW,LINETHICK;
先行带B:REF((HHV(H,Parm3)+LLV(H,Parm3))/2,Parm2),COLOR909090;
STICKLINE(先行带A<先行带B,先行带A,先行带B,2,-1),COLOR339933;
STICKLINE(先行带A>=先行带B,先行带A,先行带B,2,-1),COLOR0033CC;
PLOYLINE(1,先行带A),COLORYELLOW;
REFX(PLOYLINE(1,基准线),Parm2),COLORFF6DD8;
REFX(PLOYLINE(1,转换线),Parm2),COLORAAFF99;

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方商学院,期魔方专业量化投研平台,能给用户提供期货量化平台软件-期货指标编写-麦语言-期货行情分析-期货多账户管理-期货量化交易策略编写-编写指标-MT4toCTP,为金融从业人员更多专业决策辅助。

请登录后发表评论

    没有回复内容