魔方学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方学院:如何用BBI、ATR指标编写通道线(附带源码)

图片[1]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

编写需求:

BBI常被很多交易者拿来判断行情多空的指标之一。

价格在BBI之上为多头,价格在BBI之下为空头。

有位粉丝朋友想用BBI指标结合ATR指标来形成通道线,来识别真假突破。

【老师,请用BBI指标和ATR指标编写一个通道线指标,当价格超过2倍ATR时,BBI+ATR之上为多头,K线显示红色,BBI-ATR之下为空头,K线显示绿色。中间表示为震荡,K线显示黄色。】

效果展示:

图片[2]|魔方学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

源码展示:

IsMainIndex:=myinput(1);
Parm1:=myinput(3);
Parm2:=myinput(6);
Parm3:=myinput(12);
Parm4:=myinput(24);
Parm5:=myinput(14);
BBI:(MA(C,Parm1)+MA(C,Parm2)+MA(C,Parm3)+MA(C,Parm4))/4;
MTR:=MAX(MAX((H-L),ABS(REF(C,1)-H)),ABS(REF(C,1)-L));
ATR:=MA(MTR,Parm5);
UPBBI:BBI+ATR;
DOWNBBI:BBI-ATR;
STICKLINE(C>UPBBI,O,C,3,0),COLORRED;
STICKLINE(C<DOWNBBI,O,C,3,0),COLORGREEN; 
STICKLINE(C<UPBBI&&C>DOWNBBI,O,C,3,0),COLORYELLOW;

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

魔方学院,期魔方专业量化投研平台,能给用户提供期货量化平台软件-期货指标编写-麦语言-期货行情分析-期货多账户管理-期货量化交易策略编写-编写指标-MT4toCTP,为金融从业人员更多专业决策辅助。

请登录后发表评论

    没有回复内容