期魔方专业量化投研平台,提供期货量化平台软件|期货指标编写|期货行情分析|期货多账户管理|期货量化交易策略编写-编写指标|MT4TOCTP|MT4|量化交易|魔方学院|期货模拟软件

魔方学院:如何编写量价匹配指标(附带源码)

图片[1]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

编写需求:

在市场中,量价时空,几乎是所有交易者都要去考虑的要素之一。

而用这个指标,就能将量价之间的变化直观的体现出来。

【老师,能在成交量上表示出不同的量价的关系吗?比如:量价齐升,量价齐跌,量价背离这些关系】

效果展示:

紫红色表示量价齐升,淡红色表示价升量跌,绿色表示量价齐跌,淡绿色表示价跌量升。

图片[2]|期魔方专业量化投研平台,提供期货量化平台软件|期货指标编写|期货行情分析|期货多账户管理|期货量化交易策略编写-编写指标|MT4TOCTP|MT4|量化交易|魔方学院|期货模拟软件

源码展示:

IsMainIndex:=myinput(0);
Parm1:=myinput(5);
Parm2:=myinput(10);
CJL:V,VOLSTICK;
M5:MA(V,Parm1),LINETHICK2,COLORWHITE;
M10:MA(V,Parm2),LINETHICK2,COLORYELLOW;
JS:=C>REF(C,1);
JD:=C<REF(C,1);
LS:=V>REF(V,1);
LD:=V<REF(V,1);
LJQS:=JS&&LS;
LJQD:=JD&&LD;
LSJD:=JD&&LS;
LDJS:=JS&&LD;
量价齐升:IF(LJQS,V,DRAWNULL),COLORMAGENTA;
量价齐跌:IF(LJQD,V,DRAWNULL),COLORCYAN;
价跌量升:IF(LSJD,V,DRAWNULL),COLORLIGREEN;
价升量跌:IF(LDJS,V,DRAWNULL),COLORLIGRAY;
STICKLINE(LJQS,0,V,3,0),COLORMAGENTA;
STICKLINE(LJQD,0,V,3,0),COLORCYAN;
STICKLINE(LSJD,0,V,3,0),COLORLIGREEN;
STICKLINE(LDJS,0,V,3,0),COLORLIGRAY;

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

期魔方专业量化投研平台,能给用户提供期货量化平台软件|期货指标编写|期货行情分析|期货多账户管理|指标编写|策略编写|编写指标|MT4TOCTP|期货模拟软件|MT4|魔方学院,为金融从业人员更多专业决策辅助-魔方商学院

请登录后发表评论

    没有回复内容