魔方商学院:魔改经典KD指标,见识不一样的KD指标 ——源码分享,仅供参考

魔方商学院:魔改经典KD指标,见识不一样的KD指标 ——源码分享,仅供参考

图片[1]|魔方商学院:魔改经典KD指标,见识不一样的KD指标 ——源码分享,仅供参考

在市场上,经典指标往往经过时间的洗礼,能留存至今并不断被使用的,其设计都具有一定的合理性和可取之处。然而,随着经典指标使用者数量的不断增加,传统参数下的指标钝化问题变得不可避免。

因此,对指标进行“魔改”成为了指标使用的必经之路。今天这款魔改指标,结合了价格重心、价格高低点变化以及传统KD指标的设计思路,经过综合创新而成。

图片[2]|魔方商学院:魔改经典KD指标,见识不一样的KD指标 ——源码分享,仅供参考

传统用法是:黄线下笑脸为买入信号(多头)蓝线上哭脸为卖出信号(空头)。但增加了价格过滤后,情况则有所变化:

图片[3]|魔方商学院:魔改经典KD指标,见识不一样的KD指标 ——源码分享,仅供参考

当绿色线抬高,且黄色线下方出现笑脸时,视为多头信号,是买入的提示。

图片[4]|魔方商学院:魔改经典KD指标,见识不一样的KD指标 ——源码分享,仅供参考

当白色线降低,且蓝色线上方出现哭脸时,视为空头信号,是卖出的提示。

需要强调的是,任何单一指标都无法完全监控市场的所有变化。交易者应当密切关注这些信号,并结合其他技术分析工具以及市场信息来做出明智的交易决策。同时,风险管理至关重要,避免因误判或过度交易而造成不必要的损失。

源码展示:

IsMainIndex:=myinput(0);
Parm1:=myinput(13);
Parm2:=myinput(35);
RSV:=(C-LLV(L,Parm2))/(HHV(H,Parm2)-LLV(L,Parm2))*100;
K:=SMA(RSV,Parm1,1);
D:=SMA(K,Parm1,1);
CDP:=(H+L+C*2)/4;
LL:=LLV(L,Parm2);
HH:=HHV(H,Parm2);
VAR1:EMA(D,3),COLORGREEN,LINETHICK2;
JX:=EMA((CDP-LL)/(HH-LL)*100,9),COLORRED;
JX2:=EMA((JX/3+REF(JX,1)/3*2),2);
STICKLINE(JX-JX2>0,JX,JX2,2,0),COLORRED;
STICKLINE(JX-JX2<0,JX,JX2,2,0),COLORYELLOW;
VAR2:IF(VAR1>REF(VAR1,1),VAR1,DRAWNULL),COLORRED,LINETHICK2;
HHH:HHV(JX,169),COLORWHITE,LINETHICK2;
LLL:LLV(JX,169),COLORGREEN,LINETHICK2;
警戒线1:20,LINETHICK2;
警戒线2:80,LINETHICK2;
DRAWICON(CROSS(JX,JX2),JX2,3);
DRAWICON(CROSS(JX2,JX),JX,4);

注意:以上代码仅适用于期魔方,详情可咨询客服或您的专属顾问

源码应用于期魔方量化平台,编写案例仅供学习,不作为买卖依据。未经授权,源码请勿用于商用。

图片[3]-魔方商学院-麦语言-策略指标-指标编写-Python学习-量化学习平台-期魔方-期货量化平台软件-期货指标编写-MT4TOCTP

期魔方专业量化投研平台,能给用户提供期货量化平台软件|期货指标编写|期货行情分析|期货多账户管理|指标编写|策略编写|编写指标|MT4TOCTP|期货模拟软件|MT4|魔方学院,为金融从业人员更多专业决策辅助-魔方商学院

请登录后发表评论

    没有回复内容